Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck

CVE-2026-100691Hugo before 0.166.0 Stored XSS via lineAnchors code block option

Medium 5.4

In plain English

A medium-severity cross-site scripting in hugo from gohugoio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.2%top 93.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hugo versions 0.75.0 through 0.165.x contain a stored cross-site scripting vulnerability: the syntax highlighter does not escape the `lineAnchors` option before passing it to Chroma, which writes the value verbatim into the `id` and `href` attributes of the generated line-number markup. A crafted `lineAnchors` value supplied as a Markdown code fence attribute (or passed to the `highlight` template function) results in unescaped HTML in the rendered page, allowing arbitrary JavaScript to execute in the browsers of visitors to the generated site. This affects sites that build and publish Markdown from untrusted contributors; Hugo's security model otherwise considers content trusted input. Fixed in 0.166.0, where the `lineAnchors` value is HTML-escaped before being passed to Chroma.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12hugono fix listedDEBIAN-CVE-2026-100691
Debian:13hugono fix listedDEBIAN-CVE-2026-100691
Debian:14hugo0.166.0-1DEBIAN-CVE-2026-100691
Ubuntu:22.04:LTShugono fix listedUBUNTU-CVE-2026-100691
Ubuntu:26.04:LTShugono fix listedUBUNTU-CVE-2026-100691
Ubuntu:26.10hugono fix listedUBUNTU-CVE-2026-100691

Affected products (as reported)

VendorProductVersions
gohugoio hugo 0.75.0 – before 0.166.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References