Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck
CVE-2026-100651vllm before 0.29.0 Denial of Service via Decoder Prompt Length Bypass
Medium 6.5
In plain English
A medium-severity uncontrolled resource consumption in vllm from vllm-project. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities).
Official description
vLLM before 0.29.0 fails to enforce decoder prompt-length validation on the disaggregated serving endpoint /inference/v1/generate. When the request contains a 'features' (multimodal) payload, vllm/entrypoints/serve/disagg/serving.py builds a multimodal EngineInput directly from the caller-supplied token_ids, and GenerateRequest.token_ids (vllm/entrypoints/serve/disagg/protocol.py) is not checked against model_config.max_model_len. For multimodal processors that report skip_prompt_length_check=True (for example Nemotron Parse, Whisper, and FireRedLID), InputProcessor._validate_prompt_len() returns immediately for both encoder and decoder prompts, so an overlong prompt becomes an EngineCoreRequest and reaches the worker input-batch copy into a fixed max_model_len-wide NumPy row. A client able to reach the endpoint on an affected model configuration can therefore submit an overlong token_ids list to trigger a worker failure and denial of service. Fixed in 0.29.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | 0 – before 0.29.0 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- GitHub Security Advisory (GHSA-3mqx-f33v-vgp9) vendor-advisory
- VulnCheck Advisory: vllm before 0.29.0 Denial of Service via Decoder Prompt Length Bypass third-party-advisory