Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck
CVE-2026-100588OpenClaw before 2026.7.1 Authentication Bypass via node.invoke
High 8.3
In plain English
A high-severity incorrect authorization in OpenClaw from OpenClaw. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities).
Official description
OpenClaw (npm package 'openclaw') before 2026.7.1 does not enforce the administrator scope requirement on browser control when it is reached through the node.invoke method, although direct browser.request access requires administrator scope. In Gateway deployments that honor caller identity and narrower operator scopes, a write-scoped caller with access to a connected browser-capable node can inspect pages, navigate tabs, or interact with browser-visible applications without the configured admin requirement; practical impact depends on the browser profile and signed-in state. Shared-secret token and password callers are considered fully trusted operators under OpenClaw's security model and are not affected. The issue is fixed in 2026.7.1.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- GitHub Security Advisory (GHSA-jghr-xp78-995p) vendor-advisory
- VulnCheck Advisory: OpenClaw before 2026.7.1 Authentication Bypass via node.invoke third-party-advisory