Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck
CVE-2026-100569OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override
Medium 5.5
In plain English
A medium-severity security flaw in OpenClaw from OpenClaw. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities).
Official description
OpenClaw is an npm-distributed application. In versions >= 2026.4.25 and < 2026.8.1, the workspace environment-variable filter did not block variables ending in `_ENDPOINT`, so an untrusted workspace `.env` file could set AZURE_SPEECH_ENDPOINT. Azure Speech preferred that value over the configured region, so when a synthesis or voice-list request was made, the attacker-selected endpoint received the operator's Azure Speech key in the request header, allowing the key to be reused against the operator's Azure Speech resource. Exploitation requires an operator to start OpenClaw in attacker-controlled workspace content with Azure Speech configured with a key and region and no trusted endpoint override set. The issue is fixed in 2026.8.1.
Affected products (as reported)
Weakness: CWE-522 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
References
- GitHub Security Advisory (GHSA-pfrw-r5vr-89hw) vendor-advisory
- VulnCheck Advisory: OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override third-party-advisory