Vulnerability · Published Nov 4, 2026 · Assigned by apache

CVE-2026-100302Apache ZooKeeper: Denial of service through unbounded memory allocation in multiRead request handling

High 7.1

In plain English

A high-severity resource allocation without limits in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 55.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Allocation of Resources Without Limits or Throttling in the multiRead request handler of Apache ZooKeeper allows a remote attacker to crash the server (denial of service) with a single small request. The multiRead handler places no limit on the number of bundled read operations or on the cumulative size of the response it builds in memory. Because each operation's result is fully materialized and retained before serialization, a request that is small on the wire — within the jute.maxbuffer limit — but that references a large znode many times can force the server to allocate far more heap than the request size implies, exhausting the JVM heap and terminating the server with an OutOfMemoryError. Neither jute.maxbuffer nor largeRequestMaxBytes prevents this, as both bound only the inbound request, not the response. This issue affects Apache ZooKeeper from 3.7.0 through 3.9.6. Users are recommended to upgrade to version 3.9.7, which enforces configurable limits on the multiRead operation count and cumulative response size.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zookeeperno fix listedDEBIAN-CVE-2026-100302
Debian:13zookeeperno fix listedDEBIAN-CVE-2026-100302
Debian:14zookeeperno fix listedDEBIAN-CVE-2026-100302
Ubuntu:22.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100302
Ubuntu:24.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100302
Ubuntu:26.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100302
Ubuntu:26.10zookeeperno fix listedUBUNTU-CVE-2026-100302

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ZooKeeper 3.9.0 – through 3.9.63.8.0 – through 3.8.7

Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References