Vulnerability · Published Nov 4, 2026 · Assigned by apache

CVE-2026-100252Apache ZooKeeper: SASL authorization bypass on the client port through a client-supplied authorization ID

High 8.6

In plain English

A high-severity incorrect authorization in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.5%top 54.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authorization vulnerability in Apache ZooKeeper. When SASL authentication is enabled on the client port, the server's SASL callback handler grants every authorization identity (authzid) that a client requests, without checking it against the principal the client authenticated as. The server then tries to replace the requested identity with a canonical form of the authenticated principal, derived from the zookeeper.security.auth_to_local rules. If no rule applies to the principal, canonicalization fails and the error is only logged. The client-requested authzid then becomes the session's SASL identity for all ACL checks. An authenticated client whose principal is not covered by the auth_to_local rules can therefore claim any SASL identity. With the default rules, this includes any Kerberos principal from a realm other than the server's default realm, such as a principal from a cross-realm trusted realm. The client then gets the permissions granted to that identity in sasl ACLs. If the requested identity matches a configured zookeeper.superUser, it gets superuser access to the whole data tree. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zookeeperno fix listedDEBIAN-CVE-2026-100252
Debian:13zookeeperno fix listedDEBIAN-CVE-2026-100252
Debian:14zookeeperno fix listedDEBIAN-CVE-2026-100252
Ubuntu:22.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100252
Ubuntu:24.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100252
Ubuntu:26.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100252
Ubuntu:26.10zookeeperno fix listedUBUNTU-CVE-2026-100252

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ZooKeeper 3.9.0 – through 3.9.63.8.0 – through 3.8.7

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References