Vulnerability · Published Sep 11, 2025 · Assigned by Wordfence
CVE-2025-9634Plugin updates blocker <= 0.2 - Cross-Site Request Forgery
Medium 4.3
In plain English
A medium-severity cross-site request forgery in Plugin updates blocker from jegerwan. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities).
Official description
The Plugin updates blocker plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.2. This is due to missing or incorrect nonce validation on the pub_save action handler. This makes it possible for unauthenticated attackers to disable or enable plugin updates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jegerwan | Plugin updates blocker | 0 – through 0.2 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N