Vulnerability · Published Aug 4, 2025 · Assigned by VulDB
CVE-2025-8521givanz Vvveb Add Type post-types cross site scripting
Low 2.4
In plain English
A low-severity cross-site scripting in Vvveb from givanz. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities).
Official description
A vulnerability, which was classified as problematic, has been found in givanz Vvveb up to 1.0.5. This issue affects some unknown processing of the file /vadmin123/index.php?module=settings/post-types of the component Add Type Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. The patch is named b53c7161da606f512b7efcb392d6ffc708688d49/605a70f8729e4d44ebe272671cb1e43e3d6ae014. It is recommended to upgrade the affected component.
Affected products (as reported)
Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-318647 | givanz Vvveb Add Type post-types cross site scripting vdb-entry
- VDB-318647 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #625003 | Vvveb 1.0.5 Cross Site Scripting third-party-advisory
- https://hkohi.ca/vulnerability/11 exploit
- https://github.com/givanz/Vvveb/commit/b53c7161da606f512b7efcb392d6ffc708688d49 patch
- https://github.com/givanz/Vvveb/releases/tag/1.0.6 patch