Vulnerability · Published Jan 7, 2026 · Assigned by GitHub_M

CVE-2025-69264pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"

High 8.8

In plain English

A high-severity security flaw in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.0%top 36.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23pnpm10.33.4-r0ALPINE-CVE-2025-69264
npmpnpm10.26.0GHSA-379q-355j-w6rj

Affected products (as reported)

VendorProductVersions
pnpm pnpm > 10.0.0, < 10.26.0

Weakness: CWE-693 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References