Vulnerability · Published Jan 13, 2026 · Assigned by GitHub_M
CVE-2025-68925Jervis has a JWT Algorithm Confusion Vulnerability
Medium 6.9
In plain English
A medium-severity security flaw in jervis from samrocketman. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.2%top 95.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, the code doesn't validate that the JWT header specifies "alg":"RS256". This vulnerability is fixed in 2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | net.gleske:jervis | 2.2 | GHSA-5pq9-5mpr-jj85 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| samrocketman | jervis | < 2.2 |
Weakness: CWE-347 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N