Vulnerability · Published Jan 13, 2026 · Assigned by GitHub_M

CVE-2025-68701Jervis has Deterministic AES IV Derivation from Passphrase

High 8.7

In plain English

A high-severity broken cryptography in jervis from samrocketman. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.2%top 84.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses deterministic AES IV derivation from a passphrase. This vulnerability is fixed in 2.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavennet.gleske:jervis2.2GHSA-crxp-chh4-9ghp

Affected products (as reported)

VendorProductVersions
samrocketman jervis < 2.2

Weakness: CWE-327, CWE-340 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References