Vulnerability · Published Jan 27, 2026 · Assigned by GitHub_M
CVE-2025-68670xrdp improperly checks bounds of domain string length, which leads to Stack-based Buffer Overflow
Critical 9.1
In plain English
A critical-severity stack buffer overflow in xrdp from neutrinolabs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | xrdp | 0.10.5-r0 | ALPINE-CVE-2025-68670 |
| Alpine:v3.24 | xrdp | 0.10.5-r0 | ALPINE-CVE-2025-68670 |
| Debian:12 | xrdp | 0.9.21.1-1+deb12u2 | DEBIAN-CVE-2025-68670 |
| Debian:12 | xrdp | 0.9.21.1-1+deb12u2 | DSA-6123-1 |
| Debian:13 | xrdp | 0.10.1-3.1+deb13u1 | DEBIAN-CVE-2025-68670 |
| Debian:13 | xrdp | 0.10.1-3.1+deb13u1 | DSA-6123-1 |
| Debian:14 | xrdp | 0.10.1-4.1 | DEBIAN-CVE-2025-68670 |
| Ubuntu:25.10 | xrdp | 0.10.1-3.1+deb13u1build0.25.10.1 | UBUNTU-CVE-2025-68670 |
| Ubuntu:25.10 | xrdp | 0.10.1-3.1+deb13u1build0.25.10.1 | USN-8476-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| neutrinolabs | xrdp | < 0.10.5 |
Weakness: CWE-121 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
References
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rwvg-gp87-gh6f x_refsource_CONFIRM
- https://github.com/neutrinolabs/xrdp/commit/488c8c7d4d189514a366cd8301b6e816c5218ffa x_refsource_MISC
- https://github.com/neutrinolabs/xrdp/releases/tag/v0.10.5 x_refsource_MISC
- https://lists.debian.org/debian-lts-announce/2026/02/msg00003.html