Vulnerability · Published Jan 28, 2026 · Assigned by GitHub_M

CVE-2025-68666Discourse users archives leaked to users with moderation privileges

Medium 5.9

In plain English

A medium-severity incorrect authorization in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).

Severity (CVSS 4.0)5.9Medium
Exploit odds (30 days)0.3%top 77.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, users archives are viewable by users with moderation privileges even though moderators should not have access to the archives. Private topic/post content made by the users are leaked through the archives leading to a breach of confidentiality. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. To work around this problem, a site admin can temporarily revoke the moderation role from all moderators until the Discourse instance has been upgraded to a version that has been patched.

Affected products (as reported)

VendorProductVersions
discourse discourse < 3.5.4>= 2025.11.0-latest, < 2025.11.2>= 2025.12.0-latest, < 2025.12.1>= 2026.1.0-latest, < 2026.1.0

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References