Vulnerability · Published Dec 22, 2025 · Assigned by GitHub_M
CVE-2025-68615Net-SNMP snmptrapd crash
Critical 9.8
In plain English
A critical-severity memory corruption in net-snmp from net-snmp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 42.4% (higher than 99% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)42.4%top 1.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | net-snmp | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | net-snmp-agent-libs | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp-agent-libs | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp-agent-libs | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | net-snmp-devel | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp-devel | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp-devel | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | net-snmp-libs | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp-libs | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp-libs | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | net-snmp-perl | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp-perl | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp-perl | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | net-snmp-perl-module | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:10 | net-snmp-utils | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:8 | net-snmp-utils | 1:5.8-33.el8_10 | ALSA-2026:0750 |
| AlmaLinux:9 | net-snmp-utils | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| AlmaLinux:10 | python3-net-snmp | 1:5.9.4-15.el10_1.2 | ALSA-2026:0668 |
| AlmaLinux:9 | python3-net-snmp | 1:5.9.1-17.el9_7.1 | ALSA-2026:0696 |
| Alpine:v3.23 | net-snmp | 5.9.5.2-r0 | ALPINE-CVE-2025-68615 |
| Alpine:v3.24 | net-snmp | 5.9.5.2-r0 | ALPINE-CVE-2025-68615 |
| Debian:12 | net-snmp | 5.9.3+dfsg-2+deb12u1 | DSA-6098-1 |
| Debian:12 | net-snmp | 5.9.3+dfsg-2+deb12u1 | DEBIAN-CVE-2025-68615 |
| Debian:13 | net-snmp | 5.9.4+dfsg-2+deb13u1 | DEBIAN-CVE-2025-68615 |
| Debian:13 | net-snmp | 5.9.4+dfsg-2+deb13u1 | DSA-6098-1 |
| Debian:14 | net-snmp | 5.9.5.2+dfsg-1 | DEBIAN-CVE-2025-68615 |
| Rocky Linux:10 | net-snmp | 1:5.9.4-15.el10_1.2 | RLSA-2026:0668 |
| Rocky Linux:8 | net-snmp | 1:5.8-33.el8_10 | RLSA-2026:0750 |
| Rocky Linux:9 | net-snmp | 1:5.9.1-17.el9_7.1 | RLSA-2026:0696 |
| Ubuntu:22.04:LTS | net-snmp | 5.9.1+dfsg-1ubuntu2.9 | UBUNTU-CVE-2025-68615 |
| Ubuntu:24.04:LTS | net-snmp | 5.9.4+dfsg-1.1ubuntu3.2 | UBUNTU-CVE-2025-68615 |
| Ubuntu:25.10 | net-snmp | 5.9.4+dfsg-2ubuntu2.1 | UBUNTU-CVE-2025-68615 |
Affected products (as reported)
Weakness: CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq x_refsource_CONFIRM
- https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
- http://www.openwall.com/lists/oss-security/2026/01/09/2
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp