Vulnerability · Published Dec 22, 2025 · Assigned by GitHub_M
CVE-2025-68480Marshmallow has DoS in Schema.load(many)
Medium 5.3
In plain English
A medium-severity security flaw in marshmallow from marshmallow-code. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Marshmallow is a lightweight library for converting complex objects to and from simple Python datatypes. In versions from 3.0.0rc1 to before 3.26.2 and from 4.0.0 to before 4.1.2, Schema.load(data, many=True) is vulnerable to denial of service attacks. A moderately sized request can consume a disproportionate amount of CPU time. This issue has been patched in version 3.26.2 and 4.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-marshmallow | no fix listed | DEBIAN-CVE-2025-68480 |
| Debian:13 | python-marshmallow | 3.26.2-0+deb13u1 | DEBIAN-CVE-2025-68480 |
| Debian:14 | python-marshmallow | 3.26.2-0.1 | DEBIAN-CVE-2025-68480 |
| PyPI | marshmallow | 3.26.2 | GHSA-428g-f7cq-pgp5 |
| PyPI | marshmallow | 4.1.2 | GHSA-428g-f7cq-pgp5 |
| PyPI | marshmallow | 3.26.2, 4.1.2 | PYSEC-2026-1605 |
| Ubuntu:25.10 | python-marshmallow | no fix listed | UBUNTU-CVE-2025-68480 |
| Ubuntu:26.10 | python-marshmallow | no fix listed | UBUNTU-CVE-2025-68480 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| marshmallow-code | marshmallow | >= 3.0.0rc1, < 3.26.2>= 4.0.0, < 4.1.2 |
Weakness: CWE-405 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L