Vulnerability · Published Jan 5, 2026 · Assigned by GitHub_M

CVE-2025-68454Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI

Medium 5.2

In plain English

A medium-severity security flaw in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.2Medium
Exploit odds (30 days)0.9%top 38.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms5.8.21GHSA-742x-x762-7383
Packagistcraftcms/cms4.16.17GHSA-742x-x762-7383

Affected products (as reported)

VendorProductVersions
craftcms cms >= 5.0.0-RC1, < 5.8.21>= 4.0.0-RC1, < 4.16.17

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References