Vulnerability · Published Dec 12, 2025 · Assigned by GitHub_M

CVE-2025-67750Lightning Flow Scanner is Vulnerable to Code Injection via Unsafe Use of new Function() in APIVersion Rule

High 8.4

In plain English

A high-severity code injection in lightning-flow-scanner from Flow-Scanner. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)0.2%top 90.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Lightning Flow Scanner provides a A CLI plugin, VS Code Extension and GitHub Action for analysis and optimization of Salesforce Flows. Versions 6.10.5 and below allow a maliciously crafted flow metadata file to cause arbitrary JavaScript execution during scanning. The APIVersion rule uses new Function() to evaluate expression strings, enabling an attacker to supply a malicious expression within rule configuration or crafted flow metadata. This could compromise developer machines, CI runners, or editor environments. This issue is fixed in version 6.10.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmlightning-flow-scanner6.10.6GHSA-55jh-84jv-8mx8

Affected products (as reported)

VendorProductVersions
Flow-Scanner lightning-flow-scanner < 6.10.6

Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References