Vulnerability · Published Dec 12, 2025 · Assigned by GitHub_M

CVE-2025-67726Tornado is Vulnerable to Quadratic DoS via Crafted Multipart Parameters

High 7.5

In plain English

A high-severity uncontrolled resource consumption in tornado from tornadoweb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 54.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Tornado is a Python web framework and asynchronous networking library. Versions 6.5.2 and below use an inefficient algorithm when parsing parameters for HTTP header values, potentially causing a DoS. The _parseparam function in httputil.py is used to parse specific HTTP header values, such as those in multipart/form-data and repeatedly calls string.count() within a nested loop while processing quoted semicolons. If an attacker sends a request with a large number of maliciously crafted parameters in a Content-Disposition header, the server's CPU usage increases quadratically (O(n²)) during parsing. Due to Tornado's single event loop architecture, a single malicious request can cause the entire server to become unresponsive for an extended period. This issue is fixed in version 6.5.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8pcs0.10.18-2.el8_10.8.alma.1ALSA-2026:0930
AlmaLinux:8pcs-snmp0.10.18-2.el8_10.8.alma.1ALSA-2026:0930
Alpine:v3.23py3-tornado6.5.4-r0ALPINE-CVE-2025-67726
Alpine:v3.24py3-tornado6.5.4-r0ALPINE-CVE-2025-67726
Debian:12python-tornado6.2.0-3+deb12u4DEBIAN-CVE-2025-67726
Debian:13python-tornado6.4.2-3+deb13u2DEBIAN-CVE-2025-67726
Debian:14python-tornado6.5.4-0.1DEBIAN-CVE-2025-67726
PyPItornado6.5.3PYSEC-2025-267
PyPItornado6.5.3GHSA-jhmp-mqwm-3gq8
Rocky Linux:8pcs0:0.10.18-2.el8_10.8RLSA-2026:0930
Ubuntu:24.04:LTSpython-tornado6.4.0-1ubuntu0.4UBUNTU-CVE-2025-67726
Ubuntu:25.10python-tornado6.4.2-3ubuntu0.2UBUNTU-CVE-2025-67726

Affected products (as reported)

VendorProductVersions
tornadoweb tornado < 6.5.3

Weakness: CWE-834, CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References