Vulnerability · Published Jan 28, 2026 · Assigned by GitHub_M

CVE-2025-67723Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin

Medium 4.6

In plain English

A medium-severity cross-site scripting in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).

Severity (CVSS 3.1)4.6Medium
Exploit odds (30 days)0.2%top 87.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.

Affected products (as reported)

VendorProductVersions
discourse discourse < 3.5.4>= 2025.11.0-latest, < 2025.11.2>= 2025.12.0-latest, < 2025.12.1>= 2026.1.0-latest, < 2026.1.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L

References