Vulnerability · Published Dec 11, 2025 · Assigned by GitHub_M
CVE-2025-67716Auth0 Next.js SDK has Improper Validation of Query Parameters
Medium 5.7
In plain English
A medium-severity security flaw in nextjs-auth0 from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @auth0/nextjs-auth0 | 4.13.0 | GHSA-mr6f-h57v-rpj5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| auth0 | nextjs-auth0 | >= 4.9.0, < 4.13.0 |
Weakness: CWE-184 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N