Vulnerability · Published Dec 10, 2025 · Assigned by GitHub_M

CVE-2025-67648Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

High 7.1

In plain English

A high-severity cross-site scripting in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 91.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/shopware6.6.10.10GHSA-6w82-v552-wjw2
Packagistshopware/shopware6.7.5.1GHSA-6w82-v552-wjw2
Packagistshopware/storefront6.6.10.10GHSA-6w82-v552-wjw2
Packagistshopware/storefront6.7.5.1GHSA-6w82-v552-wjw2

Affected products (as reported)

VendorProductVersions
shopware shopware >= 6.4.6.0, < 6.6.10.10>= 6.7.0.0, < 6.7.5.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N

References