Vulnerability · Published Dec 10, 2025 · Assigned by GitHub_M
CVE-2025-67490Auth0 Next.js SDK has Improper Request Caching Lookup
Medium 5.4
In plain English
A medium-severity incorrect authorization in nextjs-auth0 from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @auth0/nextjs-auth0 | 4.11.2 | GHSA-wcgj-f865-c7j7 |
| npm | @auth0/nextjs-auth0 | 4.12.1 | GHSA-wcgj-f865-c7j7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| auth0 | nextjs-auth0 | >= 4.12.0, < 4.12.1>= 4.11.0, < 4.11.2 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N