Vulnerability · Published Dec 10, 2025 · Assigned by apache
CVE-2025-66675Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed
High 8.2
In plain English
A high-severity security flaw in Apache Struts from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.struts:struts2-core | 6.8.0 | GHSA-rg58-xhh7-mqjw |
| Maven | org.apache.struts:struts2-core | 7.1.1 | GHSA-rg58-xhh7-mqjw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Struts | 2.0.0 – through 6.7.*7.0.0 – through 7.0.* |
Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
References
- https://cwiki.apache.org/confluence/display/WW/S2-068 vendor-advisory
- https://cve.org/CVERecord?id=CVE-2025-64775 related