Vulnerability · Published Dec 9, 2025 · Assigned by GitHub_M

CVE-2025-66567ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)

Critical 9.3

In plain English

A critical-severity security flaw in ruby-saml from SAML-Toolkits. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.4%top 63.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsruby-saml1.18.0GHSA-9v8j-x534-2fx3

Affected products (as reported)

VendorProductVersions
SAML-Toolkits ruby-saml < 1.18.0

Weakness: CWE-347 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References