Vulnerability · Published Dec 5, 2025 · Assigned by GitHub_M
CVE-2025-66566yawkat LZ4 Java has a possible information leak in Java safe decompressor
High 8.2
In plain English
A high-severity security flaw in lz4-java from yawkat. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:9 | jmc | 8.2.0-18.el9_7.2 | ALSA-2026:0752 |
| AlmaLinux:9 | jmc | 8.2.0-19.el9_8.2 | ALSA-2026:20568 |
| Debian:12 | lz4-java | no fix listed | DEBIAN-CVE-2025-66566 |
| Debian:13 | lz4-java | no fix listed | DEBIAN-CVE-2025-66566 |
| Debian:14 | lz4-java | 1.11.2+ds1-1 | DEBIAN-CVE-2025-66566 |
| Maven | at.yawk.lz4:lz4-java | 1.10.1 | GHSA-cmp6-m4wj-q63q |
| Maven | net.jpountz.lz4:lz4 | no fix listed | GHSA-cmp6-m4wj-q63q |
| Maven | org.lz4:lz4-java | no fix listed | GHSA-cmp6-m4wj-q63q |
| Maven | org.lz4:lz4-pure-java | no fix listed | GHSA-cmp6-m4wj-q63q |
| Rocky Linux:9 | jmc | 0:8.2.0-19.el9_8.2 | RLSA-2026:20568 |
| Rocky Linux:9 | jmc | 0:8.2.0-18.el9_7.2 | RLSA-2026:0752 |
| Ubuntu:22.04:LTS | lz4-java | no fix listed | UBUNTU-CVE-2025-66566 |
| Ubuntu:24.04:LTS | lz4-java | no fix listed | UBUNTU-CVE-2025-66566 |
| Ubuntu:25.10 | lz4-java | no fix listed | UBUNTU-CVE-2025-66566 |
| Ubuntu:26.04:LTS | lz4-java | no fix listed | UBUNTU-CVE-2025-66566 |
| Ubuntu:26.10 | lz4-java | no fix listed | UBUNTU-CVE-2025-66566 |
Affected products (as reported)
Weakness: CWE-201 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N