Vulnerability · Published Dec 10, 2025 · Assigned by GitHub_M

CVE-2025-66474XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection

High 8.7

In plain English

A high-severity security flaw in xwiki-rendering from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)1.0%top 36.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.rendering:xwiki-rendering-xml16.10.10GHSA-9xc6-c2rm-f27p
Mavenorg.xwiki.rendering:xwiki-rendering-xml17.4.3GHSA-9xc6-c2rm-f27p
Mavenorg.xwiki.rendering:xwiki-rendering-xml17.6.0-rc-1GHSA-9xc6-c2rm-f27p

Affected products (as reported)

VendorProductVersions
xwiki xwiki-rendering < 16.10.10>= 17.0.0-rc-1, < 17.4.3>= 17.5.0-rc-1, < 17.6.0-rc-1

Weakness: CWE-95 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References