Vulnerability · Published Dec 8, 2025 · Assigned by GitHub_M
CVE-2025-66469NiceGUI Reflected XSS in ui.add_css, ui.add_scss, and ui.add_sass via Style Injection
Medium 6.1
In plain English
A medium-severity cross-site scripting in nicegui from zauberzeug. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are vulnerable to Reflected XSS through its ui.add_css, ui.add_scss, and ui.add_sass functions. The functions lack proper sanitization or encoding for the JavaScript context they generate. An attacker can break out of the intended <style> or <script> tags by injecting closing tags (e.g., </style> or </script>), allowing for the execution of arbitrary JavaScript. This issue is fixed in version 3.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | nicegui | 3.4.0 | GHSA-72qc-wxch-74mg |
| PyPI | nicegui | 3.4.0 | PYSEC-2026-1697 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| zauberzeug | nicegui | < 3.4.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N