Vulnerability · Published Dec 1, 2025 · Assigned by GitHub_M

CVE-2025-66412Angular Stored XSS Vulnerability via SVG Animation, SVG URL and MathML Attributes

High 8.5

In plain English

A high-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.4%top 67.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 21.0.2, 20.3.15, and 19.2.17, A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. This vulnerability is fixed in 21.0.2, 20.3.15, and 19.2.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2025-66412
Debian:13angular.jsno fix listedDEBIAN-CVE-2025-66412
Debian:14angular.jsno fix listedDEBIAN-CVE-2025-66412
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66412
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66412
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2025-66412
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66412
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2025-66412
npm@angular/compilerno fix listedGHSA-v4hv-rgfq-gp49
npm@angular/compiler19.2.17GHSA-v4hv-rgfq-gp49
npm@angular/compiler20.3.15GHSA-v4hv-rgfq-gp49
npm@angular/compiler21.0.2GHSA-v4hv-rgfq-gp49

Affected products (as reported)

VendorProductVersions
angular angular >= 21.0.0-next.0 < 21.0.2>= 20.0.0-next.0 < 20.3.15>= 19.0.0-next.0 < 19.2.17<= 18.2.14

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References