Vulnerability · Published Dec 2, 2025 · Assigned by GitHub_M
CVE-2025-66399SNMP Command Injection leads to RCE in Cacti
High 7.4
In plain English
A high-severity command injection in cacti from Cacti. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 10.8% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cacti is an open source performance and fault management framework. Prior to 1.2.29, there is an input-validation flaw in the SNMP device configuration functionality. An authenticated Cacti user can supply crafted SNMP community strings containing control characters (including newlines) that are accepted, stored verbatim in the database, and later embedded into backend SNMP operations. In environments where downstream SNMP tooling or wrappers interpret newline-separated tokens as command boundaries, this can lead to unintended command execution with the privileges of the Cacti process. This vulnerability is fixed in 1.2.29.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | cacti | no fix listed | DEBIAN-CVE-2025-66399 |
| Debian:13 | cacti | 1.2.30+ds1-1 | DEBIAN-CVE-2025-66399 |
| Debian:14 | cacti | 1.2.30+ds1-1 | DEBIAN-CVE-2025-66399 |
| Ubuntu:24.04:LTS | cacti | no fix listed | UBUNTU-CVE-2025-66399 |
Affected products (as reported)
Weakness: CWE-77 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
References
- https://github.com/Cacti/cacti/security/advisories/GHSA-c7rr-2h93-7gjf x_refsource_CONFIRM