Vulnerability · Published Dec 1, 2025 · Assigned by GitHub_M

CVE-2025-66205Frappe has the possibility of SQL Injection due to improper validations

High 7.1

In plain English

A high-severity SQL injection in frappe from frappe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.3%top 73.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.

Affected products (as reported)

VendorProductVersions
frappe frappe >= 15.0.0, < 15.86.0< 14.99.2

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L

References