Vulnerability · Published Nov 29, 2025 · Assigned by GitHub_M
CVE-2025-66201LibreChat is Vulnerable to Server-Side Request Forgery (SSRF) in Actions Capability
High 8.6
In plain English
A high-severity improper input validation in LibreChat from danny-avila. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| danny-avila | LibreChat | < 0.8.1-rc2 |
Weakness: CWE-20, CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-7m2q-fjwr-5x8v x_refsource_CONFIRM