Vulnerability · Published Mar 4, 2026 · Assigned by apache

CVE-2025-66168Apache ActiveMQ, Apache ActiveMQ All Module, Apache ActiveMQ MQTT Module: MQTT control packet remaining length field is not properly validated

Medium 5.4

In plain English

A medium-severity integer overflow in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.9%top 40.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. See the  following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046 Original Report: Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2025-66168
Debian:13activemqno fix listedDEBIAN-CVE-2025-66168
Mavenorg.apache.activemq:activemq-all6.2.1GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:activemq-all5.19.2GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:activemq-all6.1.9GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:activemq-mqtt6.1.9GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:activemq-mqtt5.19.2GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:activemq-mqtt6.2.1GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:apache-activemq5.19.2GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:apache-activemq6.1.9GHSA-c825-6ph3-4h84
Mavenorg.apache.activemq:apache-activemq6.2.1GHSA-c825-6ph3-4h84
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2025-66168
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2025-66168
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2025-66168
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2025-66168

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.26.0.0 – before 6.1.96.2.0 – before 6.2.1
Apache Software Foundation Apache ActiveMQ All Module 0 – before 5.19.26.0.0 – before 6.1.96.2.0 – before 6.2.1
Apache Software Foundation Apache ActiveMQ MQTT Module 0 – before 5.19.26.0.0 – before 6.1.96.2.0 – before 6.2.1

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

References