Vulnerability · Published Mar 30, 2026 · Assigned by GitHub_M

CVE-2025-66037OpenSC: Out of Bounds vulnerability

Low 3.9

In plain English

A low-severity out-of-bounds read in OpenSC from OpenSC. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.9Low
Exploit odds (30 days)0.3%top 81.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted input to the fuzz_pkcs15_reader harness causes OpenSC to perform an out-of-bounds heap read in the X.509/SPKI handling path. Specifically, sc_pkcs15_pubkey_from_spki_fields() allocates a zero-length buffer and then reads one byte past the end of that allocation. This issue has been patched in version 0.27.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12openscno fix listedDEBIAN-CVE-2025-66037
Debian:13openscno fix listedDEBIAN-CVE-2025-66037
Debian:14opensc0.27.1-1DEBIAN-CVE-2025-66037
Ubuntu:25.10openscno fix listedUBUNTU-CVE-2025-66037
Ubuntu:26.04:LTSopenscno fix listedUBUNTU-CVE-2025-66037
Ubuntu:26.10openscno fix listedUBUNTU-CVE-2025-66037

Affected products (as reported)

VendorProductVersions
OpenSC OpenSC < 0.27.0

Weakness: CWE-125 · Vector: CVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

References