Vulnerability · Published Nov 26, 2025 · Assigned by GitHub_M

CVE-2025-66035Angular HTTP Client Has XSRF Token Leakage via Protocol-Relative URLs

High 7.7

In plain English

A high-severity security flaw in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.7%top 46.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.16, 20.3.14, and 21.0.1, there is a XSRF token leakage via protocol-relative URLs in angular HTTP clients. The vulnerability is a Credential Leak by App Logic that leads to the unauthorized disclosure of the Cross-Site Request Forgery (XSRF) token to an attacker-controlled domain. Angular's HttpClient has a built-in XSRF protection mechanism that works by checking if a request URL starts with a protocol (http:// or https://) to determine if it is cross-origin. If the URL starts with protocol-relative URL (//), it is incorrectly treated as a same-origin request, and the XSRF token is automatically added to the X-XSRF-TOKEN header. This issue has been patched in versions 19.2.16, 20.3.14, and 21.0.1. A workaround for this issue involves avoiding using protocol-relative URLs (URLs starting with //) in HttpClient requests. All backend communication URLs should be hardcoded as relative paths (starting with a single /) or fully qualified, trusted absolute URLs.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2025-66035
Debian:13angular.jsno fix listedDEBIAN-CVE-2025-66035
Debian:14angular.jsno fix listedDEBIAN-CVE-2025-66035
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66035
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66035
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2025-66035
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2025-66035
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2025-66035
npm@angular/common19.2.16GHSA-58c5-g7wp-6w37
npm@angular/common20.3.14GHSA-58c5-g7wp-6w37
npm@angular/common21.0.1GHSA-58c5-g7wp-6w37

Affected products (as reported)

VendorProductVersions
angular angular >= 21.0.0-next.0, < 21.0.1>= 20.0.0-next.0, < 20.3.14< 19.2.16

Weakness: CWE-201, CWE-359 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References