Vulnerability · Published Nov 26, 2025 · Assigned by GitHub_M
CVE-2025-66030node-forge ASN.1 OID Integer Truncation
Medium 6.3
In plain English
A medium-severity integer overflow in forge from digitalbazaar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Integer Overflow vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions. This issue has been patched in version 1.3.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | node-node-forge | no fix listed | UBUNTU-CVE-2025-66030 |
| npm | node-forge | 1.3.2 | GHSA-65ch-62r8-g69g |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| digitalbazaar | forge | < 1.3.2 |
Weakness: CWE-190 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N