Vulnerability · Published Nov 25, 2025 · Assigned by GitHub_M
CVE-2025-65961Contao is vulnerable to cross-site scripting in templates
Low 3.3
In plain English
A low-severity security flaw in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | contao/core-bundle | 4.13.57 | GHSA-68q5-78xp-cwwc |
| Packagist | contao/core-bundle | 5.3.42 | GHSA-68q5-78xp-cwwc |
| Packagist | contao/core-bundle | 5.6.5 | GHSA-68q5-78xp-cwwc |
Affected products (as reported)
Weakness: CWE-87 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/contao/contao/security/advisories/GHSA-68q5-78xp-cwwc x_refsource_CONFIRM
- https://contao.org/en/security-advisories/cross-site-scripting-in-templates x_refsource_MISC