Vulnerability · Published Nov 25, 2025 · Assigned by GitHub_M
CVE-2025-65960Contao is vulnerable to remote code execution in template closures
Medium 6.6
In plain English
A medium-severity security flaw in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | contao/core-bundle | 4.13.57 | GHSA-98vj-mm79-v77r |
| Packagist | contao/core-bundle | 5.3.42 | GHSA-98vj-mm79-v77r |
| Packagist | contao/core-bundle | 5.6.5 | GHSA-98vj-mm79-v77r |
Affected products (as reported)
Weakness: CWE-351 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H