Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M
CVE-2025-65946Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug
High 8.1
In plain English
A high-severity command injection in Roo-Code from RooCodeInc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).
Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.7%top 46.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Prior to version 3.26.7, Due to an error in validation it was possible for Roo to automatically execute commands that did not match the allow list prefixes. This issue has been patched in version 3.26.7.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| RooCodeInc | Roo-Code | < 3.26.7 |
Weakness: CWE-77, CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-hwm7-w97p-4h8p x_refsource_CONFIRM
- https://github.com/RooCodeInc/Roo-Code/pull/7667 x_refsource_MISC
- https://github.com/RooCodeInc/Roo-Code/commit/b50104cc5987ce64f5154309d967ae8c74cfd1f3 x_refsource_MISC