Vulnerability · Published Nov 25, 2025 · Assigned by GitHub_M
CVE-2025-65944Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`
Medium 5.1
In plain English
A medium-severity security flaw in sentry-javascript from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @sentry/astro | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/aws-serverless | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/bun | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/google-cloud-serverless | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/nestjs | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/nextjs | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/node | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/node-core | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/nuxt | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/remix | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/solidstart | 10.27.0 | GHSA-6465-jgvq-jhgp |
| npm | @sentry/sveltekit | 10.27.0 | GHSA-6465-jgvq-jhgp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| getsentry | sentry-javascript | >= 10.11.0, < 10.27.0 |
Weakness: CWE-201 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L
References
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-6465-jgvq-jhgp x_refsource_CONFIRM
- https://github.com/getsentry/sentry-javascript/pull/17475 x_refsource_MISC
- https://github.com/getsentry/sentry-javascript/commit/a820fa2891fdcf985b834a5b557edf351ec54539 x_refsource_MISC
- https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0 x_refsource_MISC