Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M

CVE-2025-65106LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates

High 8.3

In plain English

A high-severity security flaw in langchain from langchain-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.5%top 55.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlangchain-core1.0.7GHSA-6qv9-48xg-fc7f
PyPIlangchain-core0.3.80GHSA-6qv9-48xg-fc7f
PyPIlangchain-core0.3.80, 1.0.7PYSEC-2026-1518

Affected products (as reported)

VendorProductVersions
langchain-ai langchain >= 1.0.0, < 1.0.7< 0.3.80

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References