Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M

CVE-2025-65102PJSIP is vulnerable to buffer overflow in Opus PLC

High 8.7

In plain English

A high-severity buffer overflow in pjproject from pjsip. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.3%top 72.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PJSIP is a free and open source multimedia communication library. Prior to version 2.16, Opus PLC may zero-fill the input frame as long as the decoder ptime, while the input frame length, which is based on stream ptime, may be less than that. This issue affects PJSIP users who use the Opus audio codec in receiving direction. The vulnerability can lead to unexpected application termination due to a memory overwrite. This issue has been patched in version 2.16.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23pjproject2.16.0-r0ALPINE-CVE-2025-65102
Alpine:v3.24pjproject2.16.0-r0ALPINE-CVE-2025-65102
Debian:14asterisk1:22.9.0+dfsg+~cs6.16.60671434-1DEBIAN-CVE-2025-65102

Affected products (as reported)

VendorProductVersions
pjsip pjproject < 2.16

Weakness: CWE-120 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References