Vulnerability · Published Dec 5, 2025 · Assigned by apache

CVE-2025-65082Apache HTTP Server: CGI environment variable override

Medium 6.5

In plain English

A medium-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 41.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9httpd2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:9httpd-core2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9httpd-devel2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:10httpd-filesystem2.4.63-4.el10_1.3ALSA-2025:23932
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9httpd-filesystem2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9httpd-manual2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9httpd-tools2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+4044+ea5f78b1.4ALSA-2025:23732
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9mod_ldap2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:9mod_lua2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8mod_md1:2.0.8-8.module_el8.10.0+4088+57f011c1.2ALSA-2025:23732
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9mod_proxy_html1:2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9mod_session2.4.62-7.el9_7.3ALSA-2025:23919
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+4088+57f011c1.7ALSA-2025:23732
AlmaLinux:9mod_ssl1:2.4.62-7.el9_7.3ALSA-2025:23919
Alpine:v3.20apache22.4.66-r0ALPINE-CVE-2025-65082
Alpine:v3.21apache22.4.66-r0ALPINE-CVE-2025-65082
Alpine:v3.22apache22.4.66-r0ALPINE-CVE-2025-65082
Alpine:v3.23apache22.4.66-r0ALPINE-CVE-2025-65082
Alpine:v3.24apache22.4.66-r0ALPINE-CVE-2025-65082
Debian:12apache22.4.66-1~deb12u1DEBIAN-CVE-2025-65082
Debian:13apache22.4.66-1~deb13u1DEBIAN-CVE-2025-65082
Debian:14apache22.4.66-1DEBIAN-CVE-2025-65082
Rocky Linux:10httpd0:2.4.63-4.el10_1.3RLSA-2025:23932
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40045+6ce8579b.6RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+2061+8d03fdec.5RLSA-2025:23732
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1984+1bed3124.4RLSA-2025:23732
Rocky Linux:9httpd0:2.4.62-7.el9_7.3RLSA-2025:23919
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2025:23732
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2025:23732
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2025:23732
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2025:23732
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+2061+8d03fdec.4RLSA-2025:23732
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2025:23732
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.18USN-7968-1
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.18UBUNTU-CVE-2025-65082
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.10USN-7968-1
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.10UBUNTU-CVE-2025-65082
Ubuntu:25.10apache22.4.64-1ubuntu3.2UBUNTU-CVE-2025-65082
Ubuntu:25.10apache22.4.64-1ubuntu3.2USN-7968-1
Ubuntu:26.04:LTSapache22.4.66-2ubuntu1UBUNTU-CVE-2025-65082

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.0 – through 2.4.65

Weakness: CWE-150 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References