Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M
CVE-2025-64767hpke-js reuses AEAD nonces
Critical 9.1
In plain English
A critical-severity security flaw in hpke-js from dajiaji. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
hpke-js is a Hybrid Public Key Encryption (HPKE) module built on top of Web Cryptography API. Prior to version 1.7.5, the public SenderContext Seal() API has a race condition which allows for the same AEAD nonce to be re-used for multiple Seal() calls. This can lead to complete loss of Confidentiality and Integrity of the produced messages. This issue has been patched in version 1.7.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @hpke/core | 1.7.5 | GHSA-73g8-5h73-26h4 |
Affected products (as reported)
Weakness: CWE-323 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/dajiaji/hpke-js/security/advisories/GHSA-73g8-5h73-26h4 x_refsource_CONFIRM
- https://github.com/dajiaji/hpke-js/commit/94a767c9b9f37ce48d5cd86f7017d8cacd294aaf x_refsource_MISC
- https://github.com/dajiaji/hpke-js/blob/b7fd3592c7c08660c98289d67c6bb7f891af75c4/packages/core/src/senderContext.ts#L22-L34 x_refsource_MISC