Vulnerability · Published Nov 25, 2025 · Assigned by GitHub_M
CVE-2025-64761OpenBao Privileged Operator Identity Group Root Escalation
High 7.5
In plain English
A high-severity security flaw in openbao from openbao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/openbao/openbao | 2.4.4 | GHSA-7ff4-jw48-3436 |
| Go | github.com/openbao/openbao | no fix listed | GO-2025-4156 |
Affected products (as reported)
Weakness: CWE-266 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/openbao/openbao/security/advisories/GHSA-7ff4-jw48-3436 x_refsource_CONFIRM
- https://github.com/openbao/openbao/pull/2143 x_refsource_MISC
- https://github.com/openbao/openbao/commit/16bb0ccd37a502930a289d434cbe4e7b4edd66e5 x_refsource_MISC