Vulnerability · Published Nov 10, 2025 · Assigned by GitHub_M
CVE-2025-64509Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input (via CPU)
High 7.5
In plain English
A high-severity resource allocation without limits in bugsink from bugsink. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.6, a specially crafted Brotli-compressed envelope can cause Bugsink to spend excessive CPU time in decompression, leading to denial of service. This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink 2.0.6. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-fc2v-vcwj-269v/CVE-2025-64508.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | bugsink | 2.0.6 | GHSA-rrx3-2x4g-mq2h |
| PyPI | bugsink | 2.0.6 | PYSEC-2026-1227 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/bugsink/bugsink/security/advisories/GHSA-rrx3-2x4g-mq2h x_refsource_CONFIRM