Vulnerability · Published Nov 7, 2025 · Assigned by GitHub_M
CVE-2025-64486calibre is vulnerable to arbitrary code execution when opening FB2 files
Critical 9.3
In plain English
A critical-severity security flaw in calibre from kovidgoyal. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
calibre is an e-book manager. In versions 8.13.0 and prior, calibre does not validate filenames when handling binary assets in FB2 files, allowing an attacker to write arbitrary files on the filesystem when viewing or converting a malicious FictionBook file. This can be leveraged to achieve arbitrary code execution. This issue is fixed in version 8.14.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | calibre | 6.13.0+repack-2+deb12u5 | DEBIAN-CVE-2025-64486 |
| Debian:13 | calibre | 8.5.0+ds-1+deb13u1 | DEBIAN-CVE-2025-64486 |
| Debian:14 | calibre | 8.14.0+ds+~0.10.5-1 | DEBIAN-CVE-2025-64486 |
| Ubuntu:22.04:LTS | calibre | no fix listed | UBUNTU-CVE-2025-64486 |
| Ubuntu:24.04:LTS | calibre | no fix listed | UBUNTU-CVE-2025-64486 |
| Ubuntu:25.10 | calibre | no fix listed | UBUNTU-CVE-2025-64486 |
| Ubuntu:26.04:LTS | calibre | no fix listed | UBUNTU-CVE-2025-64486 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| kovidgoyal | calibre | < 8.14.0 |
Weakness: CWE-73 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H