Vulnerability · Published Nov 7, 2025 · Assigned by GitHub_M

CVE-2025-64434KubeVirt Improper TLS Certificate Management Handling Allows API Identity Spoofing

Medium 4.7

In plain English

A medium-severity improper authentication in kubevirt from kubevirt. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.7Medium
Exploit odds (30 days)0.2%top 90.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

KubeVirt is a virtual machine management add-on for Kubernetes. Prior to 1.5.3 and 1.6.1, due to the peer verification logic in virt-handler (via verifyPeerCert), an attacker who compromises a virt-handler instance, could exploit these shared credentials to impersonate virt-api and execute privileged operations against other virt-handler instances potentially compromising the integrity and availability of the VM managed by it. This vulnerability is fixed in 1.5.3 and 1.6.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gokubevirt.io/kubevirt1.5.3GHSA-ggp9-c99x-54gp
Gokubevirt.io/kubevirt1.6.1GHSA-ggp9-c99x-54gp
Gokubevirt.io/kubevirt1.5.3, 1.6.0-beta.0.0.20250730135146-231dc69723f3, 1.6.1GO-2025-4107

Affected products (as reported)

VendorProductVersions
kubevirt kubevirt < 1.5.3>= 1.6.0-alpha.0, < 1.6.1

Weakness: CWE-287 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

References