Vulnerability · Published Apr 3, 2026 · Assigned by GitHub_M
CVE-2025-64340FastMCP has a Command Injection vulnerability - Gemini CLI
Medium 6.7
In plain English
A medium-severity OS command injection in fastmcp from jlowin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | fastmcp | 3.2.0 | GHSA-m8x7-r2rg-vh5g |
| PyPI | fastmcp | 3.2.0 | PYSEC-2026-2475 |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g x_refsource_CONFIRM
- https://github.com/PrefectHQ/fastmcp/pull/3522 x_refsource_MISC