Vulnerability · Published Nov 26, 2025 · Assigned by GitHub_M
CVE-2025-64332Suricata is vulnerable to a stack overflow on larger compressed data
High 7.5
In plain English
A high-severity stack buffer overflow in suricata from OISF. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Prior to versions 7.0.13 and 8.0.2, a stack overflow that causes Suricata to crash can occur if SWF decompression is enabled. This issue has been patched in versions 7.0.13 and 8.0.2. A workaround for this issue involves disabling SWF decompression (swf-decompression in suricata.yaml), it is disabled by default; set decompress-depth to lower than half your stack size if swf-decompression must be enabled.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.24 | suricata | 8.0.2-r0 | ALPINE-CVE-2025-64332 |
| Debian:13 | suricata | 1:7.0.10-1+deb13u2 | DEBIAN-CVE-2025-64332 |
| Debian:14 | suricata | 1:8.0.2-1 | DEBIAN-CVE-2025-64332 |
| Ubuntu:22.04:LTS | suricata | no fix listed | UBUNTU-CVE-2025-64332 |
| Ubuntu:24.04:LTS | suricata | no fix listed | UBUNTU-CVE-2025-64332 |
| Ubuntu:25.10 | suricata | no fix listed | UBUNTU-CVE-2025-64332 |
Affected products (as reported)
Weakness: CWE-121 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H