Vulnerability · Published Nov 7, 2025 · Assigned by GitHub_M

CVE-2025-64329containerd CRI server: Host memory exhaustion through Attach goroutine leak

Medium 6.9

In plain English

A medium-severity memory leak in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.2%top 93.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. Versions 1.7.28 and below, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4, and 2.2.0-beta.0 through 2.2.0-rc.1 contain a bug in the CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. To workaround this vulnerability, users can set up an admission controller to control accesses to pods/attach resources.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12containerd1.6.20~ds1-1+deb12u3DEBIAN-CVE-2025-64329
Debian:13containerd1.7.24~ds1-6+deb13u1DEBIAN-CVE-2025-64329
Debian:14containerd1.7.24~ds1-10DEBIAN-CVE-2025-64329
Gogithub.com/containerd/containerd1.7.29GO-2025-4108
Gogithub.com/containerd/containerd1.7.29GHSA-m6hq-p25p-ffr2
Gogithub.com/containerd/containerd/v22.1.5GHSA-m6hq-p25p-ffr2
Gogithub.com/containerd/containerd/v22.0.7GHSA-m6hq-p25p-ffr2
Gogithub.com/containerd/containerd/v22.2.0GHSA-m6hq-p25p-ffr2
Gogithub.com/containerd/containerd/v22.0.7, 2.1.5, 2.2.0GO-2025-4108
Ubuntu:22.04:LTScontainerd1.6.12-0ubuntu1~22.04.10UBUNTU-CVE-2025-64329
Ubuntu:25.10containerd1.7.24~ds1-8ubuntu1.1UBUNTU-CVE-2025-64329
Ubuntu:24.04:LTScontainerd-app1.7.28-0ubuntu1~24.04.2UBUNTU-CVE-2025-64329
Ubuntu:25.10containerd-app2.1.3-0ubuntu3.1UBUNTU-CVE-2025-64329

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.7.29< 2.0.7>= 2.1.0-beta.0, < 2.1.5>= 2.2.0-beta.0, < 2.2.0

Weakness: CWE-401 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References